谁先倒(简单模拟)

在这里插入图片描述
sample input

1 1
6
8 10 9 12
5 10 5 10
3 8 5 12
12 18 1 13
4 16 12 15
15 1 1 16

sample output

A
1

思路

简单模拟即可,细节点需注意
通过数据得知:
注意
1.甲乙都败不喝酒直接下一轮
2.酒量为0的时候不算结束


代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    int n,s1,s2;
    int x,a,y,b;
    scanf("%d%d",&s1,&s2);
    scanf("%d",&n);
    int f=0,j=0,k=0;
    while(n--){
        scanf("%d%d%d%d",&x,&a,&y,&b);
        if(f||(x+y!=a&&x+y!=b)||(x+y==a&&a==b)) continue;  //同时败不喝酒
        if(x+y==a){
            s1--;
            j++;
            if(s1<0) f=1;  //等于0不算倒下
        }
        if(x+y==b){
            s2--;
            k++;
            if(s2<0) f=2;
        }
    }
    if(f==1)
        printf("A\n%d",k);
    if(f==2)
        printf("B\n%d",j);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值