1138 Postorder Traversal (25 分)先序和中序序列求后序序列第一个数字

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

题意:先序和中序序列求后序序列第一个数字
思路:用柳神的方法连建树都不用建了,参数为prel,inl,inr,设置了一个flag变量来纪录有没有输出后序序列的第一个数字,如果输出了flag就为true。
递归终止条件inl>inr||flag=true
其他语句为先得出先序的第一个数在中序的索引,然后执行递归,判断如果flag=false就打印in[l]。一个比较坑的点是,vector在全局定义的时候,在主函数中要重新定义它的大小

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>

using namespace std;

bool flag = false;
vector<int> pre,in;

void postorder(int prel,int inl,int inr) {
	if(inl > inr || flag == true) return;
	int i = inl;
	while(in[i] != pre[prel]) i++;
	postorder(prel + 1,inl,i - 1);
	postorder(prel + i - inl + 1,i + 1,inr);
	if(flag == false) {
		printf("%d",in[i]);
		flag = true;
	}
}

int main() {
	int n;
	scanf("%d",&n);
	pre.resize(n);
	in.resize(n);
	for(int i = 0;i < n;i++) scanf("%d",&pre[i]);
	for(int i = 0;i < n;i++) scanf("%d",&in[i]);
	postorder(0,0,n - 1);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值