A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.
Output Specification:
For each query, print in a line Yes if the set is a vertex cover, or No if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
题意:给出n个顶点和m条边的信息,再给出k个查询,每个查询中都包含着一些顶点,问图的每一条边是否至少包含其中查询给出的一个顶点,包含的话输出Yes,不包含的话输出No。
思路:如果照着题意这样去的话可能会比较麻烦,不过可以换个思路,在给出的每个查询里面只要所有的顶点包含图中所有的边即可。在输入边的数据的时候,用二维vector存储,在for循环遍历的时候将每个顶点添加每条边的编号,编号从0~n-1,然后在查询的过程中引入hash的vector,将查询设计到的每条边都放入hash中,设值为1,最后只需要遍历所有的边,只要有一个为0的话就输出No,反之输出Yes。
#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
using namespace std;
int main() {
int n,m,k;
scanf("%d%d",&n,&m);
vector<int> v[n];
for(int i = 0;i < m;i++) {
int t1,t2;
scanf("%d%d",&t1,&t2);
v[t1].push_back(i);
v[t2].push_back(i);
}
scanf("%d",&k);
for(int i = 0;i < k;i++) {
int num,nv;
scanf("%d",&nv);
vector<int> hash(m,0);
int flag = 0;
for(int j = 0;j < nv;j++) {
scanf("%d",&num);
for(int l = 0;l < v[num].size();l++) {
hash[v[num][l]] = 1;
}
}
for(int j = 0;j < m;j++) {
if(hash[j] == 0) {
printf("No\n");
flag = 1;
break;
}
}
if(flag == 0) {
printf("Yes\n");
}
}
return 0;
}