1063 Set Similarity (25 分) set集合

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and N​t is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^4) and followed by M integers in the range [0,10 ^​9]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意:输入n个集合,然后再输入k组查询,每组查询分别是两个集合之间的查询,nc:两个集合不同公共数字的个数,nt是两个集合中的总的不同元素的个数
思路:题目比较难理解,两个集合不同公共数字的个数是指两个集合连着看,比如第一和第二个集合,87和101就是两个集合不同公共数字的个数。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

int main() {
	int n,m,k;
	scanf("%d",&n);
	vector<set<int> > v(n);
	for(int i = 0;i < n;i++) {
		scanf("%d",&m);
		int x;
		for(int j = 0;j < m;j++) {
			scanf("%d",&x);
			v[i].insert(x);
		}
	}
	scanf("%d",&k);
	int a,b;
	for(int i = 0;i < k;i++) {
		scanf("%d%d",&a,&b);
		int nc = 0,nt = v[b - 1].size();
		for(set<int>::iterator it = v[a - 1].begin();it != v[a - 1].end();it++) {
			if(v[b - 1].find(*it) == v[b - 1].end()) {
				nt++;
			} else {
				nc++;
			}
		}
		double ans = (double)nc / nt * 100;
		printf("%.1lf%%\n",ans);
	}
 	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值