On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.
Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.
Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.
Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI
题意:给出两个字符串,第一个是原始字符串,第二个是键盘坏了以后的输入的字符串,求键盘坏了哪几个键
思路:设两个字符串为s1和s2,然后将s1遍历过去,只要在s2中找不到那个字符并且没有加入到ans中,就将这个字符转为大写加入到ans中。
#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
using namespace std;
int main() {
string s1,s2;
cin >> s1 >> s2;
int length1 = s1.length();
string ans;
for(int i = 0;i < length1;i++) {
if(s2.find(s1[i]) == -1 && ans.find(toupper(s1[i])) == -1) {
ans += toupper(s1[i]);
}
}
cout << ans << endl;
return 0;
}