1077 Kuchiguse (20)(20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
思路:
emmm……感觉出这个题的人怕是想卖萌= = 这是一道字符串的题目,每次输入一个字符串的时候都从串尾开始比较,如果没有相同的部分就输出nai,如果有就用string类里面的assign取出这部分。
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
using namespace std;
int main()
{
int n;
string s1, s2;
cin >> n;
getchar();
getline(cin, s1);
for (int i = 0; i < n - 1; i++)
{
getline(cin, s2);
int j = 0;
while (s1.length() - j >= 1 && s2.length() - j >= 1 && s1[s1.length() - 1 - j] == s2[s2.length() - 1 - j])
j++;
if (j == 0)
{
cout << "nai" << endl;
return 0;
}
else
s1.assign(s1, s1.length() - j, j);
}
cout << s1 << endl;
return 0;
}