1024 Palindromic Number (25)(25 分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
思路:
N的范围是10^10,相加之后可能超出int范围,所以这用string类型 。两个字符串相加,需要从尾到头一位一位加,要注意一下每一位的进位。判断回文的话,只需要把字符串reverse一下,然后比较两个是否相等即可。还要注意的是,输入的数可能本就是个回文数。
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
string sum(string n,string m)
{
string t = "";
int c = 0;
for (int i = 0; i < n.length() && i < m.length(); i++)
{
int add = n[i] - '0' + m[i] - '0' + c;
c = add / 10;
add %= 10;
t = char(add + '0') + t;
}
if(c)
t = char(c + '0') + t;
return t;
}
int main()
{
string n;
int k, i;
cin >> n >> k;
for (i = 0; i < k; i++)
{
string m = n;
reverse(m.begin(), m.end());
if (n == m)
break;
n = sum(n, m);
}
cout << n << endl;
cout << i << endl;
return 0;
}