HDU 2844 Coins [多重背包]

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

给了钱的种类和数量,求不超过给定价值的最大价值的种类数;
也是写了这道题才知道的操作,先对数据求一个多重背包,这时dp数组里就存了最大价值为i时可以组合出的最大价值,最后只要将dp[1->V]遍历一次,dp[i]==i就说明能组合出这种钱数,ans++;

#include <iostream>
#include <cmath>
#include<queue>
#include <map>
#include <stdio.h>
#include<cstring>
#include <algorithm>
#include<cstdlib>
#include<vector>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=100005;
int dp[maxn],t[maxn],v[maxn];
void zeroone(int vi,int wi,int maxweight)
{
    for(int j=maxweight;j>=wi;j--)
    dp[j]=max(dp[j],dp[j-wi]+vi);
}

void comp(int vi,int wi,int maxweight)
{
    for(int j=wi;j<=maxweight;j++)
    dp[j]=max(dp[j],dp[j-wi]+vi);
}

void multi(int vi,int wi,int ki,int maxweight)
{
    if(wi*ki>maxweight)
        comp(vi,wi,maxweight);
    else
    {
        int mtem=1;
        while(ki-mtem>=0)
        {
            zeroone(mtem*vi,mtem*wi,maxweight);
            ki-=mtem;
            mtem*=2;
        }
        zeroone(ki*vi,ki*wi,maxweight);
    }
}
int main()
{
    int n,V;
    while(cin>>n>>V,n||V)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&v[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&t[i]);
        for(int i=1;i<=n;i++)
            multi(v[i],v[i],t[i],V);
        int ans=0;
        for(int i=1;i<=V;i++)
            if(dp[i]==i)ans++;
        cout<<ans<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值