poj 1151(线段树+扫描线)

                                                                                                                                         Atlantis
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20311 Accepted: 7666

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 


题目链接:http://poj.org/problem?id=1151
题目大意:给你若干个矩形,求其覆盖的面积;
 
思路:
硬来肯定是要超时的,首先容易想到的是容斥原理,不过解起来也相当麻烦,反正我是没写出来。
第二的当然是扫描线~\(≧▽≦)/~啦啦啦,纯粹的扫描线也是可以过的,当然也可以用树状数组优化。
扫描线的讲解请点击:http://blog.csdn.net/saber_acher/article/details/51103749
扫描线代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <map>
#include <vector>
using namespace std;
struct Rectangle
{
    double x1,y1,x2,y2;
     Rectangle(){}
     Rectangle(double _x1,double _y1,double _x2,double _y2):x1(_x1),x2(_x2),y1(_y1),y2(_y2){}
};
vector<Rectangle>rects;
double unionArea(const vector<Rectangle>& rects)
{
    if(rects.empty()) return 0;
    typedef pair<double,pair<int,int> >Event;
    vector<Event>event;
    vector<double>ys;
    for(int i=0;i<rects.size();i++)
    {
        ys.push_back(rects[i].y1);
        ys.push_back(rects[i].y2);
        event.push_back(Event(rects[i].x1,make_pair(1,i)));
        event.push_back(Event(rects[i].x2,make_pair(-1,i)));
    }
    sort(ys.begin(),ys.end());
    ys.erase(unique(ys.begin(),ys.end()),ys.end());
    sort(event.begin(),event.end());
    double ret=0;
    vector<int>countt(ys.size()-1,0);
    for(int i=0;i<event.size();i++)
    {
        double x=event[i].first;
        int delta=event[i].second.first;
        int rectangle=event[i].second.second;
        double y1=rects[rectangle].y1,y2=rects[rectangle].y2;
        for(int j=0;j<ys.size();j++)
        {
            if(y1<=ys[j]&&ys[j]<y2)
                countt[j]+=delta;
        }
        double cutlength=0;
        for(int j=0;j<ys.size()-1;j++)
        {
            if(countt[j]>0)
                cutlength+=ys[j+1]-ys[j];
        }
        if(i+1<event.size())
            ret+=cutlength*(event[i+1].first-x);
    }
    return ret;
}
int main()
{
    int n,cas=0;
    double a,b,c,d;
    while(cin>>n)
    {
        if(!n)
          break;
        rects.clear();
        for(int i=1;i<=n;i++)
        {
            cin>>a>>b>>c>>d;
            rects.push_back(Rectangle(a,b,c,d));
        }

        cout<<"Test case #"<<++cas<<endl;
        printf("Total explored area: %.2lf\n\n",unionArea(rects));
    }
    return 0;
}

线段树优化后的代码:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
struct data
{
    double x1,x2,y;
    int flag;
    }a[801];
double hash[201];
double sum[801];
int col[801];
inline bool cp(data a,data b){return a.y<b.y;}
void pushup(int size,int l,int r)
{
    if(col[size])sum[size]=hash[r+1]-hash[l];
    else if(l==r)sum[size]=0;
    else sum[size]=sum[size*2]+sum[size*2+1];
}
void update(int L,int R,int flag,int l,int r,int size)
{
    if(L<=l&&R>=r)
    {
        col[size]+=flag;
        pushup(size,l,r);
        return;
    }
    int m=(l+r)/2;
    if(L<=m)update(L,R,flag,l,m,size*2);
    if(R>m)update(L,R,flag,m+1,r,size*2+1);
    pushup(size,l,r);
}
int main()
{
    int n,t=1;
    while(cin>>n)
    {
    if(n==0)break;
    double x1,y1,x2,y2;
    for(int i=1;i<=n;i++)
    {
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            a[2*i-1].x1=a[2*i].x1=x1;
            a[2*i-1].x2=a[2*i].x2=x2;
            a[2*i-1].y=y1;a[2*i].y=y2;
            a[2*i-1].flag=1;a[2*i].flag=-1;
            hash[2*i-1]=x1;hash[2*i]=x2;
     }
        sort(a+1,a+2*n+1,cp);sort(hash+1,hash+2*n+1);
        memset(col,0,sizeof(col));
        memset(sum,0,sizeof(sum));
        double ans=0;
        for(int i=1;i<=2*n;i++)
        {
            int l=lower_bound(hash+1,hash+2*n+1,a[i].x1)-hash;
            int r=lower_bound(hash+1,hash+2*n+1,a[i].x2)-hash-1;
            if(l<=r)update(l,r,a[i].flag,1,2*n,1);
            ans+=sum[1]*(a[i+1].y-a[i].y);
        }
        printf("Test case #%d\nTotal explored area: %.2lf\n\n",t++,ans);
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值