hdu 4283 You Are the One (区间dp)

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3357    Accepted Submission(s): 1529



Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

Output
  For each test case, output the least summary of unhappiness .
 

Sample Input
  
  
2   5 1 2 3 4 5 5 5 4 3 2 2
 

Sample Output
  
  
Case #1: 20 Case #2: 24
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online

题意:这道题的题意实在是含糊不清,一开始直接排个序算了下,结果wa

n 个屌丝,每个人独有一个屌丝度,原本是必须按序号上台,但是给你一个队列,入队顺序是固定的,你可以选择入队的人是马上出队还是停留。

此处就是区间dp的运用了
dp[l][r]代表[l,r]区间内的人的最优解。

考虑第l个人,可能是在这个区间内第1~r-l+1个出队。
当第l个人是第k个出队。
也就是说有k-1个人在他之前出队。
由于入队的顺序已知,第一个人即l 一定是第一个入队,也就是说l排在队列的最下层。
这也就说明这k-1个人必定就是[l+1,l+k-1]中的这些人,这些人必须在l之前出队。
由此就诞生出了子问题。
  
     dp[l][r]=min(dp[l][r],val[l]*(k-1)+k*(sum[r]-sum[l+k-1])+dp[l+1][l+k-1]+dp[l+k][r]);

其中,val[]数组是屌丝度,sum[]数组是屌丝度的前缀和,k代表的是l是第几个出队。

代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
int sum[maxn],val[maxn];
int dp[maxn][maxn];
int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        int n;
        scanf("%d",&n);
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
            sum[i]+=val[i]+sum[i-1];
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
        for(int j=i+1;j<=n;j++)
          dp[i][j]=1e9;
        for(int len=1;len<=n;len++)
        {
            for(int l=1;l+len-1<=n;l++)
            {
                int r=l+len-1;
                for(int k=1;k<=len;k++)
                {
                    dp[l][r]=min(dp[l][r],val[l]*(k-1)+k*(sum[r]-sum[l+k-1])+dp[l+1][l+k-1]+dp[l+k][r]);
                }
            }
        }
        printf("Case #%d: %d\n",t,dp[1][n]);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值