Grab The Tree(博弈)(异或和)

                          Problem F. Grab The Tree

                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
                                       Total Submission(s): 119    Accepted Submission(s): 84

 Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

 Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 Sample Input

1 3 2 2 2 1 2 1 3

Sample Output

Q

Source

2018 Multi-University Training Contest 3

 

设sum为所有点权的异或和,AA为先手得分,BB为后手得分。

  • 若sum=0,则A=BA=B,故无论如何都是平局。
  • 否则考虑sum二进制下最高的1所在那位,一定有奇数个点那一位为1。若先手拿走任意一个那一位为1的点,则B该位为0,故先手必胜。

时间复杂度O(n)。

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int a,t;
        scanf("%d",&a);
        int ans=0;
        for(int i=0;i<a;i++)
        {
            scanf("%d",&t);
            ans^=t;
        }
        for(int i=1;i<a;i++)
            scanf("%d%d",&t,&t);
        if(ans==0) printf("D\n");
        else printf("Q\n");
    }
    return 0;
}

 

这题数据比较水,一开始写了一个选边的也过了。

#include<bits/stdc++.h>
using namespace std;

int a[100005];

int main()
{

    int T;
    scanf("%d",&T);
    while(T--)
    {
        int num,cmax=0,t,ans1=0,ans2=0,x,y,vis[100005]={1};
        scanf("%d",&num);
        for(int i=0;i<num;i++)
           {
               scanf("%d",&a[i]);
               ans1^=a[i];
           }
        for(int i=1;i<num;i++)
            {
                scanf("%d%d",&x,&y);
                if(vis[x]==1&&vis[y]==1)
                if(ans1^a[x]>ans2^a[y])
                {
                    ans1^=a[x];
                    ans2^=a[y];
                    vis[y]=0;
                }
                else
                {
                    ans2^=a[x];
                    ans1^=a[y];
                    vis[x]=0;
                }
            }

        if(ans2>ans1) printf("T\n");
        else if(ans1==ans2)   printf("D\n");
        else printf("Q\n");

    }
    return 0;
}




 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值