Pinball(物理题)

                                              Pinball

             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
                              Total Submission(s): 0    Accepted Submission(s): 0


 

Problem Description

There is a slope on the 2D plane. The lowest point of the slope is at the origin. There is a small ball falling down above the slope. Your task is to find how many times the ball has been bounced on the slope.

It's guarantee that the ball will not reach the slope or ground or Y-axis with a distance of less than 1 from the origin. And the ball is elastic collision without energy loss. Gravity acceleration g=9.8m/s2.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

The first line of each test case contains four integers a, b, x, y (1 ≤ a, b, -x, y ≤ 100), indicate that the slope will pass through the point(-a, b), the initial position of the ball is (x, y).

 

 

Output

Output the answer.

It's guarantee that the answer will not exceed 50.

 

 

Sample Input

 

1 5 1 -5 3

 

 

Sample Output

2

题意:有一个小球,从静止在重力作用下,落在一个斜面上,每次接触后就反弹,问在斜面上弹几次。

看到物理题格外亲切,尤其是这种不用自己算,g还等于9.8的题,格外令人开心。

将速度与加速分成斜面法向和斜面切向,每两次弹起之间的时间相同,嗯,没错,图大概长这样。

#include<bits/stdc++.h>
#define show(a) cout<<#a<<'='<<a<<endl;
#define ind(a) scanf("%lf",&a)
#define in(a) scanf("%d",&a)
using namespace std;

int main()
{
   int T;
   double a,b,x,y;
   const double pi=acos(-1.);
   const double g=9.8;
   int ans;
   in(T);
   while(T--)
   {
       ind(a);ind(b);ind(x);ind(y);
       ans=1;
       double tan=b/a;//show(tan);
       double sin=b/sqrt(b*b+a*a);//show(sin);
       double y0=-x/a*b;
       double h=y+x/a*b;//show(h);
       double t=sqrt(2*h/g);//show(t);
       double vy=g*t*sin;//show(vy);
       double s=sqrt(y0*y0+x*x);//show(s);
       while(s>0)
       {
           s-=vy*2*t+g*sin*2*t*t;//show(s);
           vy+=g*sin*2*t;//show(vy);
           ans++;
       }
       ans--;
       printf("%d\n",ans);
   }
   return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值