C++STL队列的应用
【题目】卡片游戏(题目来自刘汝佳《算法竞赛入门》)
桌上又一叠牌,从第一张牌(即位于顶面的牌)开始从上往下依次编号为1~n。当至少还剩两张牌时进行以下操作:把第一张牌扔掉,然后把新的第一张放到整叠牌的最后。输入n,输出每次扔掉的牌,以及最后剩下的牌。
样例输入:7
样例输出:1 3 5 7 4 2 6
#include<iostream>
#include<queue>
using namespace std;
int main()
{
int i,n;
queue<int>q;
cin>>n;
for(i=1;i<=n;i++)
{
q.push(i);
}
while(q.size()>=2)
{
cout<<q.front()<<' ';
q.pop();
q.push(q.front());
q.pop();
}
cout<<q.front()<<endl;
return 0;
}
C++STL的队列和堆栈的使用:包含头文件#include<queue>,#include<stack>
首先定义一个队列或者堆栈,<queue>int q,<stack>int s;
q.pop(),q.push(x),q.empty(),q.size(),q.front();s.pop(),s.push(x),s.top();s.size();
链表的创建,尾插法
#include<stdio.h>
#include<stdlib.h>
struct node{
int data;
struct node* next;};
typedef struct node node;
void print(node *head)
{
node *p;
p=head;
while(p)
{
printf("%d ",p->data);
p=p->next;
}
printf("\n");
}
void Free(node *head)
{
node *p;
p=NULL;
while(head)
{
p=head->next;
free(head);
head=p;
}
}
node* delete(node *head,int key)
{
node *p,*q;
p=head;
q=p;
if(head==NULL)
{
printf("链表为空\n");
return head;
}
while(p->next&&p->data!=key)
{
q=p;
p=p->next;
}
if(p->data==key)
{
if(p==head)
{
head=p->next;
}
else
{
q->next=p->next;
}
free(p);
printf("删除成功\n");
}
else
printf("链表中无此数据。\n");
return head;
}
int main()
{
int n,key;
node *head,*tail,*p;
head=tail=p=NULL;
while(scanf("%d",&n)==1)
{
p=(node *)malloc(sizeof(node));
p->data=n;
p->next=NULL;
if(head==NULL)
head=p;
else
tail->next=p;
tail=p;
}
print(head);
printf("输入你想删除的值:\n");
scanf("%d",&key);
head=delete(head,key);
print(head);
Free(head);
printf("%d\n",head->data);
return 0;
}
运行结果: