Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 6506 | Accepted: 3514 |
Description
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.
Input
Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.
Output
For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.
Sample Input
3 0 1 10 10 1 0 1 2 10 1 0 10 10 2 10 0 0
Sample Output
8
题意:从0出发转一圈遍历每个点再回来
思路:几乎是裸的旅行商问题,只是因为每个点可以经过多次,所以用Floyd搞一下求求最短路即可,用的是递归的方法写的,应该比较好懂
#include<cstdio>
#include<cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
#define MAXN 12
#define INF 1000000000
int n;
int d[MAXN][MAXN];
int dp[1<<MAXN][MAXN];
void floyd(){
for(int k=0;k<=n;k++){
for(int i=0;i<=n;i++){
for(int j=0;j<=n;j++){
d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
}
}
}
}
//访问过的节点集合为S,当前点为v
int rec(int s,int v){
if(dp[s][v]>=0)//已经遍历过这种状态
return dp[s][v];
if(s==(1<<(n+1))-1&&v==0){//已经访问过所有节点并回到0
return dp[s][0]=0;
}
int res=INF;
for(int u=0;u<=n;u++){
if(!(s>>u&1))//没有访问过u{
res=min(res,rec(s|(1<<u),u)+d[v][u]);
}
return dp[s][v]=res;
}
int main()
{
while(scanf("%d",&n)){
if(n==0)
break;
for(int i=0;i<=n;i++){
for(int j=0;j<=n;j++){
scanf("%d",&d[i][j]);
}
}
floyd();
memset(dp,-1,sizeof(dp));
printf("%d\n",rec(0,0));
}
}