题目
【题目描述】
一个迷宫由R行C列格子组成,有的格子里有障碍物,不能走;有的格子是空地,可以走。
给定一个迷宫,求从左上角走到右下角最少需要走多少步(数据保证一定能走到)。只能在水平方向或垂直方向走,不能斜着走。
【输入】
第一行是两个整数,R和C,代表迷宫的长和宽。( 1<= R,C <= 40)
接下来是R行,每行C个字符,代表整个迷宫。
空地格子用‘.’表示,有障碍物的格子用‘#’表示。
迷宫左上角和右下角都是‘.’。
【输出】
输出从左上角走到右下角至少要经过多少步(即至少要经过多少个空地格子)。计算步数要包括起点和终点。
【输入样例】
5 5
..###
#....
#.#.#
#.#.#
#.#..
【输出样例】
9
代码
#include<iostream>
#include<queue>
using namespace std;
const int N = 50;
char g[N][N];
int n, m;
bool st[N][N]; // 标记数组
int dir[4][2] = { -1,0,0,1,1,0,0,-1 }; // 方向数组
struct node {
int x, y, step;
node(int x, int y, int step) :x(x), y(y), step(step) {}
};
queue<node> q;
void push(int x, int y, int step) { // 将点(x,y)入队
q.emplace(x, y, step);
st[x][y] = true;
}
bool check(int x, int y) {
return x >= 1 && x <= n && y >= 1 && y <= m && g[x][y] == '.' && !st[x][y];
}
int bfs() {
push(1, 1, 1);
while (q.size()) {
node t = q.front();
q.pop();
for (int i = 0; i < 4; i++) {
int nx = t.x + dir[i][0], ny = t.y + dir[i][1];
if (check(nx, ny)) {
push(nx, ny, t.step + 1);
if (nx == n && ny == m) return t.step + 1;
}
}
}
return -1;
}
int main() {
cin >> n >> m;
for (int i = 1; i <= n; i++)
for (int j = 1; j <= m; j++) cin >> g[i][j];
cout << bfs() << endl;
return 0;
}