Cube--(三维树状数组)

Total Submission(s) : 5   Accepted Submission(s) : 4
Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

Input
Multi-cases. First line contains N and M, M lines follow indicating the operation below. Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation. If X is 1, following x1, y1, z1, x2, y2, z2. If X is 0, following x, y, z.
 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

Sample Output
  
  
1 0 1

树状数组模式2的三维形式(区间更新,单点求值),主要是选取哪些点进行updata,在起点增加了值后在哪些点消掉这些值(在区域外面相邻的影响到的点),下面文章写的很好很清晰

文章:https://wenku.baidu.com/view/1e51750abb68a98271fefaa8

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
#define M 102
int n,m;
int tree[M][M][M];
inline int lowbit(int i)
{
    return i&(-i);
}
void add(int x,int y,int z)
{
    int i,j,k;
    for(i=x;i<=n;i+=lowbit(i))
        for(j=y;j<=n;j+=lowbit(j))
            for(k=z;k<=n;k+=lowbit(k))
    {
        tree[i][j][k]++;
    }
}
int sum(int x,int y,int z)
{
    int i,j,k,res=0;
    for(i=x;i>0;i-=lowbit(i))
        for(j=y;j>0;j-=lowbit(j))
            for(k=z;k>0;k-=lowbit(k))
    {
        res+=tree[i][j][k];
    }
    return res;
}
int main()
{
    int i,op,x1,y1,z1,x2,y2,z2;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(tree,0,sizeof(tree));
        for(i=1;i<=m;i++)
        {
            scanf("%d",&op);
            if(op==1)
            {
                scanf("%d%d%d%d%d%d",&x1,&y1,&z1,&x2,&y2,&z2);
                add(x1,y1,z1);
                add(x2+1,y2+1,z2+1);
                add(x2+1,y1,z1);
                add(x1,y2+1,z1);
                add(x1,y1,z2+1);
                add(x2+1,y2+1,z1);
                add(x2+1,y1,z2+1);
                add(x1,y2+1,z2+1);
            }
            else
            {
                scanf("%d%d%d",&x1,&y1,&z1);
                printf("%d\n",sum(x1,y1,z1)&1);
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值