HDU3584Cube(三维树状数组)

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1818    Accepted Submission(s): 943



Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N).
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

Sample Output
  
  
1 0 1

三维树状数组,dp2[x][y][z]为数据的值,dp1[x][y][z]辅助记录
其实还有种方法可以水过去

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("in.txt","r",stdin)
#define WW freopen("out.txt","w",stdout)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;

const int maxn = 110;

int dp1[maxn][maxn][maxn];
int dp2[maxn][maxn][maxn];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        while(m--)
        {
            int choose;
            scanf("%d",&choose);
            if(choose == 1)
            {
                int x1,y1,z1,x2,y2,z2;
                scanf("%d %d %d %d %d %d",&x1,&y1,&z1,&x2,&y2,&z2);
                for(int i=x1;i<=x2;i++)
                {
                    for(int j=y1;j<=y2;j++)
                    {
                        dp1[i][j][z1] ++;
                        dp1[i][j][z2+1] --;
                    }
                }
            }
            else
            {
                int x,y,z;
                scanf("%d%d%d",&x,&y,&z);
                for(int i=1;i<=n;i++)
                {
                    dp1[x][y][i] += dp1[x][y][i-1];
                    dp1[x][y][i-1] = 0;
                    dp2[x][y][i] += dp1[x][y][i];
                }
                dp1[x][y][n] = 0;
                printf("%d\n",dp2[x][y][z]&1);
            }
        }
    }
    return 0;
}
-----------------------------------下面这种有种脑洞大开的感觉--------------------------------------
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("in.txt","r",stdin)
#define WW freopen("out.txt","w",stdout)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;

int a[10010][10];

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int j = 0;
        while(m--)
        {
            int choose;
            scanf("%d",&choose);
            if(choose == 1)
            {
                scanf("%d %d %d %d %d %d",&a[j][0],&a[j][1],&a[j][2],&a[j][3],&a[j][4],&a[j][5]);
                j++;
            }
            else
            {
                int sum = 0;
                int x,y,z;
                scanf("%d%d%d",&x,&y,&z);
                for(int k=0; k<j; k++)
                {
                    if(x >= a[k][0] && x <= a[k][3] && y >= a[k][1] && y <= a[k][4] && z >= a[k][2] && z <=a[k][5])
                        sum++;
                }
                printf("%d\n",sum&1);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值