POJ 3169 Layout

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9520 Accepted: 4563

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.


查分约束系统:

分析:

 对于任意i号奶牛,1<=i<N,在距离上应该满足:

D[i+1] - D[i] >= 0
对于每个好感的描述(i,j,k),假设i<=j,体现到距离上的要求就是:
D[j] - D[i] <= k
对于每个反感的描述(i,j,k),假设i<=j,体现到距离上的要求就是:
D[j] - D[i] >= k

写成我们约定的形式:
D[i] - D[i+1] <= 0 
D[j] -D[i ]<= k
D[i] - D[j] <= - k

1.对于差分不等式,a - b <= c ,建一条 b 到 a 的权值为 c 的边,求的是最短路,得到的是最大值(本题求的就是最大值),对于不等式 a - b >= c ,建一条 b 到 a 的权值为 c 的边,求的是最长路,得到的是最小值。

2.如果检测到负环,那么无解。

3.如果d[]没有更新,那么可以是任意解。



#include <stdio.h>
#include <string.h>
int N, ML, MD;
struct node
{
	int u;
	int v;
	int w;
} e[20005];
int dist[1005];
int vis[1005];
int Bellman_Ford()
{
	int i, j;
	memset(dist, 0x3f, sizeof(dist));
	memset(vis, 0, sizeof(vis));
	dist[1] = 0;
	for(i = 1; i < N; i++)
	{
		for(j = 1; j <= ML + MD; j++)
		{
			if(dist[e[j].u] + e[j].w < dist[e[j].v])
				dist[e[j].v] = dist[e[j].u] + e[j].w;
		}
	}
	for(j = 1; j <= ML + MD; j++)
	{
		if(dist[e[j].u] + e[j].w < dist[e[j].v])
			return -1;
	}
	if(dist[N] == 0x3f3f3f3f)
		return -2;
	return dist[N];
}
int main()
{
	int i;
	while(scanf("%d%d%d", &N, &ML, &MD) != EOF)
	{
		for(i = 1; i <= ML; i++)
			scanf("%d%d%d", &(e[i].u), &(e[i].v), &(e[i].w));
		for(i = ML + 1; i <= ML + MD; i++)
		{
			scanf("%d%d%d", &(e[i].v), &(e[i].u), &(e[i].w));
			e[i].w *= -1;
		}
		printf("%d\n", Bellman_Ford());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值