ZOJ 3785 - What day is that day?

J - What day is that day?
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday
Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.



先暴力打出前50个结果,N^N发现存在长度为42的循环节,然后直接搞。另外直接写一个快速幂也能过。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <bitset>
#include <algorithm>
using namespace std;

#define N 50
#define INF 0x3f3f3f3f
#define LL long long

int a[N],sum[N];
char st[10][10]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};

int pow(int a,int b,int n){
    int ret=1;
    for (int i=0;i<b;i++){
        ret*=a;
        ret=ret%n;
    }
    return ret;
}

int main(){
    sum[0]=0;
    for (int i=1;i<=50;i++){
        a[i]=pow(i,i,7);
        sum[i]=(sum[i-1]+a[i])%7;
        //cout<<i<<' '<<a[i]<<endl;
    }
    a[0]=a[42];

    int T,n,now=6;
    scanf("%d",&T);
    while (T--){
        scanf("%d",&n);
        int S,MOD;
        S=n/42;
        MOD=n%42;
        int add=(S*sum[42])%7;
        //cout<<S<<' '<<MOD<<' '<<add<<' '<<sum[MOD]<<endl;
        printf("%s\n",st[(now+add+sum[MOD])%7]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值