最短路1010 (学习了一下map的映射)

Einbahnstrasse

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.
 

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

 

Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
 

Sample Input
  
  
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output
  
  
1. 80
 


题解:给出若干个地方,一个拖车公司所在地,几个需要拖车的地方。问将所有的车顺序拖回的最短路径。运用map进行城市之间的映射,floyd求最短距离,求和即可。

此题在于处理字符串,箭头的方向表示的就是路径的方向。

 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<map>
#define inf 99999999
using namespace std;
map<string, int> mp;//映射:城市到点
map<string, bool> bp;//映射:城市是否出现过
int grah[105][105];
int num[105];//记录需要拖车的个数
int n,c,r,cd;//cd表示要拖车的城市数量
void init()
{
    mp.clear();
    bp.clear();
    for(int i=0; i<n; i++)
    {
        num[i]=0;
        for(int j=0; j<n; j++)
        {
            if(i==j)
                grah[i][j]=0;
            else
                grah[i][j]=inf;
        }
    }
}
void input()
{
    int u,v,ans=0,val;
    string str1,str2;
    char ch1,ch2,ch3,ch4;
    cin >> str1;
    mp[str1]=ans++;
    bp[str1]=true;
    for(int i=0; i<c; i++)
    {
        cin >> str1;
        if(!bp[str1])
        {
            mp[str1]=ans++;
            bp[str1]=true;
        }
        num[mp[str1]]++;
    }
    cd=ans;
    for(int i=0; i<r; i++)
    {
        cin >> str1 >> ch1 >> ch2 >> val >> ch3 >> ch4 >> str2;
        if(!bp[str1])
        {
            mp[str1]=ans++;
            bp[str1]=true;
        }
        if(!bp[str2])
        {
            mp[str2]=ans++;
            bp[str2]=true;
        }
        u=mp[str1];
        v=mp[str2];
        if(ch1=='<')
        {
            if(val<grah[v][u])
                grah[v][u]=val;
        }
        if(ch4=='>')
        {
            if(val<grah[u][v])
                grah[u][v]=val;
        }
    }
}
void floyd()
{
    for(int k=0; k<n; k++)
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                if(grah[i][j]>grah[i][k]+grah[k][j])
                    grah[i][j]=grah[i][k]+grah[k][j];
}
int main()
{
    int cas=1;
    while(cin>>n>>c>>r)
    {
        int sum=0;
        if(n==0&&c==0&&r==0)break;
        init();
        input();
        floyd();
        for(int i=1; i<cd; i++)
        {
            sum+=(grah[0][i]+grah[i][0])*num[i];
        }
        cout<<cas++<<". "<<sum<<endl;
    }
    return 0;
}
/*
4 2 5
NewTroy Midvale Metrodale
NewTroy   <-20-> Midvale
Midvale   --50-> Bakerline
NewTroy    <-5-- Bakerline
Metrodale <-30-> NewTroy
Metrodale  --5-> Bakerline
0 0 0
*/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值