快速幂入门题之Rightmost Digit

HDU 1061
Problem Description
Given a positive integer N, you should output the most right digit of N^N
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

这道题的大致意思就是给你一个数n,让你去求n的n次方的个位数上的数。
这道题是标椎的快速幂取模题。(想看 快速幂简单讲解请看快速幂简单讲解
具体代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mode = 10;
LL fas(LL n,LL d){
    LL r=1;
    while(d){
        if(d&1)
            r = (r % mode) * (n % mode) % mode;
        d = d / 2;
        n = (n % mode) * (n % mode) % mode;
    }
    return r;
}
int main(){
    LL t,n;
    cin >> t;
    while(t--){
        cin >> n;
        cout << fas(n, n) << endl;
        
    }
}

道阻且长
自己走的路 跪着也要走完

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值