UVa 769 - Magic of David Copperfield 解题报告(思维)

56 篇文章 0 订阅

 Magic of David Copperfield 

The well-known magician David Copperfield loves to show the following trick: a square withN rows and N columns of different pictures appears on a TV screen. Let us number allthe pictures in the following order:

12$\dots$N
$\vdots$$\vdots$$\ddots$$\vdots$
N*(N-1)+1N*(N-1)+2$\dots$N*N

Each member of the audience is asked to put a finger on the upper left picture (i.e., picture numberone) and The Magic begins: the magician tells the audience to move the finger k1 times through thepictures (each move is a shift of the finger to the adjacent picture up, down, left or right providedthat there is a picture to move to), then with a slight movement of his hand he removes some of thepictures with an exclamation ``You are not there!", and ... it is true - your finger is not pointing toany of the pictures removed. Then again, he tells the audience to make k2 moves, and so on. At theend he removes all the pictures but one and smiling triumphantly declares, ``I've caught you"(applause).


Just now, David is trying to repeat this trick. Unfortunately, he had a hard day before, and youknow how hard to conjure with a headache. You have to write a program that will help David tomake his trick.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

Each test case consists of a single integer number N ($2 \le N \le 100$).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

Your program should write the following lines with numbers to the output file:


$k_1 \ x_{1,1} \ x_{1,2} \ \dots \ x_{1,m1}$

$k_2 \ x_{2,1} \ x_{2,2} \ \dots \ x_{2,m2}$

$\dots$

$k_e \ x_{e,1} \ x_{e,2} \ \dots \ x_{e,me}$


where ki is a number of moves the audience should make on the i-th turn ($2N \le k \le 10000$).All kishould be different (i.e. ki <> kj when i <> j). $x_{i,1}, x_{i,2}, \dots, x_{i,mi}$are the numbers of the picturesDavid should remove after the audience will make ki moves (the number of the pictures removed isarbitrary, but each picture should be listed only once, and at least one picture should be removed oneach turn).


A description of the every next turn should begin with a new line. All numbers on each line shouldbe separated by one or more spaces. After e iterations, all pictures except one should be removed.

Sample input 

1

3

Sample Output 

8     4 6
13    9
10    7 1
7     8
11    3 5

    解题报告: 很有意思的一题。给定一n*n矩阵,其中为1到n*n所有数字。求一方法,每次任意走(上下左右)k步,删除一些数字;直到只剩下一个数字。

    刚开始,我是这样想的:正方形矩阵可以这样分类可以按照(i+j)的奇偶性分为两组,这样每次走奇数步,删除边界的一个数,直到删除到最后一个数就可以了。

    写完后WA了。再看一遍题意,发现要求k不能相同。ok,改下k,每次不同,+2。运行一遍,发现n=100时k超了10000……

    问题就来了,每次删除一个数是不够的。再想一方案,仍然每次走奇数步,每次删除右下角的一整斜行数,A了。

    其实就是一思维题,细心好好想想就很容易了。代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iomanip>
using namespace std;
#define ff(i, n) for(int i=0;i<(n);i++)
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define dff(i, n, m) for(int i=(n);i>=(m);i--)
typedef long long LL;
typedef unsigned long long ULL;
void work();
int main()
{
#ifdef ACM
    freopen("in.txt", "r", stdin);
#endif // ACM
    work();
}

/***************************************************/

void work()
{
    int T;
    scanf("%d", &T);

    fff(cas, 1, T)
    {
        int n;
        scanf("%d", &n);

        typedef vector<int> vint;
        map<int, vint> mint;

        fff(i, 1, n) fff(j, 1, n)
            mint[i+j].push_back((i-1)*n + j);

        int k = 199;
        dff(i, n+n, 3)
        {
            printf("%d", k+=2);
            for(vint::iterator it = mint[i].begin(); it != mint[i].end(); it++)
                printf(" %d", *it);
            puts("");
        }

        if(T-cas) puts("");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值