GCD

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6. 
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem: 
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

3
1 1
10 2
10000 72

Sample Output

1
6
260

题目大致意思是说给出两个数n和m,m<=n,有多少个x满足1<=x<=n并且gcd(x,n)>=m;

思路分析:因为x和n有gcd可以设x = a * d,n = a * b,则公约数为a,且b与d互质,要求n >= a>=m。因为n>=x,所以b >= d;要求x的个数也就是要求d的个数,求出每一个b下面与b互质的个数,所有的b求出来,就可以就出所有符合要求的d的个数。我们可以根据a的范围对a进行枚举,这样就可以得到b,用欧拉函数求出在这个b下d的个数。有一个问题就是枚举a时范围仍然很大,可以缩下范围。我们先看,我们枚举时,当i<sqrt(n),假设a=n / i, 当i>sqrt(n)之后 有b=n/i,我们观察到当n%i==0时,会出现一种情况,就是a*b==n。所以我们就可以只需要枚举sqrt(n)种情况,然后和它对应的情况就是 n/i。

#include <iostream>
#include <algorithm>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cmath>
#include <stack>
#include <map>
#define ll long long
#define INF 0x3f3f3f3f
#define mod 1000000007;
using namespace std;
ll eular(ll n)//欧拉函数模板
{
    ll m = (ll)sqrt(n + 0.5);
    ll ans = n;
    for(ll i=2; i<=m; i++)
    {
        if(n%i==0) ans = ans / i * (i - 1);
        while(n%i==0) n /= i;
    }
    if(n>1) ans = ans / n * (n - 1);
    return ans;
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        ll x,y,ans = 0;
        cin>>x>>y;
        for(ll i=1; i<=sqrt(x+0.5); i++)
            if(x%i==0)
            {
                if(i>=y)
                    ans += eular(x/i);
                if(x/i>=y&&i*i!=x)//小细节注意一下,计算sqrt(x)右边的i*i==x时,在上个语句已经执行  //(避免)完全平方算两次
                    ans += eular(i);
            }
        cout<<ans<<endl;
    }
    return 0;
}

借鉴了大神的代码。大神代码

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值