hd2588_GCD

GCD


题目描述:

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

输入:
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

输出:
For each test case,output the answer on a single line.

样例输入:
3
1 1
10 2
10000 72

样例输出:
1
6
260

思路:
题目意思即统计比n小并且与n的最大公因子大于等于m的数的个数。
思路一:从m开始,筛选n的因子的倍数的数,直到n,统计有多少个数被筛选掉。
代码:

#include <bits/stdc++.h>
 
using namespace std;
int vis[100000005];
int main()
{
    long long t,a,b;
    cin>>t;
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        cin>>a>>b;
        int cou=0;
        for(int i=b;i<=a;i++)
        {
            if(a%i!=0)continue;
            for(int j=1;;j++)
            {
                if(i*j>a)break;
                if(!vis[i*j]){
                vis[i*j]=1;
                cou++;}
            }
        }
        cout<<cou<<"\n";
    }
    return 0;
}

提交运行错误,原因是n的范围太大,数组无法开这么大来记录。

思路二:用set容器来保存n的因子的倍数,输出set的大小。

#include <bits/stdc++.h>
 
using namespace std;
int main()
{
    int t,a,b;
    cin>>t;
    while(t--)
    {
        set<int>vis;
        cin>>a>>b;
        for(int i=b;i<=a;i++)
        {
            if(a%i!=0)continue;
            for(int j=1;;j++)
            {
                if(i*j>a)break;
                vis.insert(i*j);
            }
        }
        cout<<vis.size()<<"\n";
    }
    return 0;
}

可以运行,但是内存超限。

思路三(正确):利用欧拉函数。GCD(X,N)>=M 即 GCD(X/M,N/M)=1,就可以利用欧拉函数,求出X/M的个数。注意优化。
AC代码:

#include <bits/stdc++.h>
 
using namespace std;
int oula(int n)//计算欧拉函数值,即小于n并且与n互素的数的个数
{
    int m=(int)sqrt(n+0.5);
    int ans=n;
    for(int i=2;i<=m;i++)
    if(n%i==0){
        ans=ans/i*(i-1);
        while(n%i==0)
            n/=i;
    }
    if(n>1)ans=ans/n*(n-1);
    return ans;
}
int main()
{
    std::ios::sync_with_stdio(false);//这行目的是加速输入输出,可以去掉。
    int t,a,b;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        int s=0;
        for(int i=1;i*i<=a;i++)//i*i是为了优化,不然会超时。
        {
            if(a%i!=0)continue;
            if(i>=b&&i*i!=a)//大于等于b的最大公因子i
                s+=oula(a/i);
            if(a/i>=b)
                s+=oula(i);
        }
        cout<<s<<"\n";
    }
    return 0;
}

注意:
如果循环这样写,还是会超时。

for(int i=1;i<=a;i++)
 {
      if(a%i!=0)continue;
       if(i>=b)
          s+=oula(a/i);
 }

题目来源:
科大OJ
杭电OJ

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值