UVA 673


Parentheses Balance

You are given a string consisting of parentheses () and [].    A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct, (A ) and [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output

A sequence of Yes or No on the output file.

Sample Input

3
([])
(([()])))
([()[]()])()

 Sample Output

Yes
No
Yes


/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */
package one;

import java.util.Scanner;
import java.util.Stack;

/**
 *
 * @author Administrator
 */
public class a673 {

    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        int a = in.nextInt();
        in.nextLine();
        for (int i = 0; i < a; i++) {
            String b = in.nextLine();
            if (print(b) == true) {
                System.out.println("Yes");
            } else {
                System.out.println("No");
            }
        }
    }

    public static boolean print(String s) {
        Stack<Character> ss = new Stack<Character>();
        for (int i = 0; i < s.length(); i++) {
            char c = s.charAt(i);
            if (c == '(') {
                ss.push('(');
            }
            if (c == '[') {
                ss.push('[');
            }
            if (c == ')'&& !ss.isEmpty()) {
                if (ss.pop() == '(' ) {
                    continue;
                } else {
                    return false;
                }
            }
            if (c == ']'&& !ss.isEmpty()) {
                if (ss.pop() == '[' ) {
                    continue;
                } else {
                    return false;
                }
            }
            if (c == ')' || c == ']') {
                if (ss.size() == 0) {
                    return false;
                }
                if (ss.pop() != c) {
                    return false;
                }
            }
        }
        if (!ss.isEmpty()) {
            return false;
        }
        return true;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值