数据结构实验之排序四:寻找大富翁

Problem Description

2015胡润全球财富榜调查显示,个人资产在1000万以上的高净值人群达到200万人,假设给出N个人的个人资产值,请你快速找出排前M位的大富翁。

Input

首先输入两个正整数N( N ≤ 10^6)和M(M ≤ 10),其中N为总人数,M为需要找出的大富翁数目,接下来给出N个人的个人资产,以万元为单位,个人资产数字为正整数,数字间以空格分隔。

Output

一行数据,按降序输出资产排前M位的大富翁的个人资产值,数字间以空格分隔,行末不得有多余空格。

 

Example Input
6 3
12 6 56 23 188 60
Example Output
188 60 56
Hint

请用堆排序完成。 

code:
#include <stdio.h>
int a[15];
void heapadjust(int s, int m)
{
    int t = a[s];
    for(int j = 2*s;j<=m;j*=2)
    {
        if(j<m&&a[j]>a[j+1]) j++;
        if(t<a[j]) break;
        a[s] = a[j];
        s = j;
    }
    a[s] = t;
}
void heapcreat(int m)
{
    for(int i = m/2;i>0;i--)
    {
        heapadjust(i, m);
    }
}
void heapsort(int m)
{
    int t;
    for(int i = m;i>1;i--)
    {
        t = a[1];
        a[1] = a[i];
        a[i] = t;

        heapadjust(1, i-1);
    }
}

int main()
{
    int n, m;
    scanf("%d%d", &n, &m);
    for(int i = 1;i<=m;i++)
    {
        scanf("%d", &a[i]);
    }
    heapcreat(m);
    for(int i = m+1;i<=n;i++)
    {
        int x;
        scanf("%d", &x);
        if(x<a[1]) continue;
        a[1] = x;
        heapcreat(m);
    }
    heapsort(m);
    for(int i = 1;i<=m;i++)
    {
        if(i == m) printf("%d\n", a[i]);
        else printf("%d ", a[i]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值