正方形

Problem Description
给出四个点,判断这四个点能否构成一个正方形。
Input
 输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。

Output
 每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。
Sample Input
20 0 1 0 1 1 0 1-1 0 0 -2 1 0 2 0
Sample Output
YESNO
code:

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		
		Scanner reader = new Scanner(System.in);
		int t;
		t = reader.nextInt();
		while(t-->0)
		{
		
			Point p1 = new Point(reader.nextInt(), reader.nextInt());
			Point p2 = new Point(reader.nextInt(), reader.nextInt());
			Point p3 = new Point(reader.nextInt(), reader.nextInt());
			Point p4 = new Point(reader.nextInt(), reader.nextInt());
			double a, b, c, d;
			a = p1.length(p2);
			b = p2.length(p3);
			c = p3.length(p4);
			d = p4.length(p1);
			if(a == b&&b == c&&c == d)//菱形成立
			{
				double e = p2.length(p4);
				if(a+d == e)//证明有直角,正方形成立
				{
					System.out.println("YES");
				}
				else
				{
					System.out.println("NO");
				}
			}
			else
			{
				System.out.println("NO");
			}
		}
	}

}
class Point 
{
	int x, y;
	public Point(int x, int y)
	{
		this.x = x;
		this.y = y;
	}
	public double length(Point p1)
	{
		return (x-p1.x)*(x-p1.x)+(y-p1.y)*(y-p1.y);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值