UVA 10935 Throwing cards away I

Description

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at thebottom. The following operation is performed aslong as there are at least two cards in the deck:Throw away the top card and movethe card that is now on the top of thedeck to the bottom of the deck.Your task is to find the sequence of discardedcards and the last, remaining card.

 

Input

Each line of input (except the last) contains anumber n ≤ 50. The last line contains ‘0’ andthis line should not be processed.

 

Output

For each number from the input produce twolines of output. The first line presents the sequenceof discarded cards, the second line reportsthe last remaining card. No line will haveleading or trailing spaces. See the sample for theexpected format.

 

Sample Input

7
19
10

6
0

 

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4

 

 

解题思路:简单的队列题,现将1~n张卡牌入队,然后按照丢掉下一张牌,再将下一张牌放入队列尾部这样的操作顺序进行循环,直到只剩下最后一张牌。需要注意的是初始只有一张卡牌的特殊情况

 

 

#include<iostream>  
#include<cstdio>  
#include<stack>  
#include<string>
#include<vector>
#include<sstream>
#include<math.h>
#include<queue>
using namespace std;

int main() {
	
	int n;
	queue<int> cards;
	while (scanf("%d", &n) != EOF&&n != 0)
	{
		for (int i = 1; i < n+1; i++)
		{
			cards.push(i);
		}
		printf("Discarded cards:");
		if (cards.size() == 1)
		{
			printf("\n");
		}
		while (cards.size()>=2)
		{
			int j;
			j = cards.front();
			cards.pop();
			if (cards.size() == 1)
			{
				printf(" %d\n",j);
			}
			else
			{
				printf(" %d,",j);
			}			
			j = cards.front();
			cards.pop();
			cards.push(j);
		}

		printf("Remaining card: %d\n",cards.front());
		cards.pop();

	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值