百炼 2075:Tangled in Cables(Kruskal)

描述You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.输入Only one town will be given in an input.

  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form


< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.输出The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).样例输入

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

样例输出

Need 10.2 miles of cable

 

经典的生成树的题

 

#include<string>
#include<algorithm>
#include<iostream>
#include<iomanip>
#include<map>
using namespace std;

double total;
map<string,int> name;
int a,b;
int fa[2000];

struct node
{
    int A;
    int B;
    double dis;
}house[2000];

bool cmp(node A,node B)
{
    return A.dis<B.dis;
}
void init(int k)
{
    for(int i=0;i<k;i++)
    {
        fa[i]=i;
    }
}

int find(int x)
{
    if(fa[x]==x)
        return x;
    else
        return fa[x]=find(fa[x]);
}

void _union(int x,int y)
{
    int tempx=find(x);
    int tempy=find(y);
    if(tempx!=tempy)
        fa[tempx]=tempy;
}

int main()
{
   cin>>total>>a;
   for(int i=0;i<a;i++)
   {
       string s;
       cin>>s;
       name[s]=i;
   }
   init(a);

   cin>>b;
   for(int i=0;i<b;i++)
   {
        string s1,s2;
        double d;
        cin>>s1>>s2>>d;
        house[i].A=name[s1];
        house[i].B=name[s2];
        house[i].dis=d;
   }

   sort(house,house+b,cmp);

   double sum=0;
   int flag=0;
   for(int i=0;i<b;i++)
   {
       if(find(house[i].A)!=find(house[i].B))
       {
           _union(house[i].A,house[i].B);
           sum+=house[i].dis;
           flag++;
       }
   }

        if(sum>total)
           cout<<"Not enough cable"<<endl;
        else
            cout<<"Need "<<sum<<setprecision(1)<<" miles of cable"<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值