POJ 1180 Batch Scheduling(斜率DP)

Batch Scheduling

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4523 Accepted: 2071

Description

There is a sequence of N jobs to be processed on one machine. The jobs are numbered from 1 to N, so that the sequence is 1,2,..., N. The sequence of jobs must be partitioned into one or more batches, where each batch consists of consecutive jobs in the sequence. The processing starts at time 0. The batches are handled one by one starting from the first batch as follows. If a batch b contains jobs with smaller numbers than batch c, then batch b is handled before batch c. The jobs in a batch are processed successively on the machine. Immediately after all the jobs in a batch are processed, the machine outputs the results of all the jobs in that batch. The output time of a job j is the time when the batch containing j finishes. 

A setup time S is needed to set up the machine for each batch. For each job i, we know its cost factor Fi and the time Ti required to process it. If a batch contains the jobs x, x+1,... , x+k, and starts at time t, then the output time of every job in that batch is t + S + (Tx + Tx+1 + ... + Tx+k). Note that the machine outputs the results of all jobs in a batch at the same time. If the output time of job i is Oi, its cost is Oi * Fi. For example, assume that there are 5 jobs, the setup time S = 1, (T1, T2, T3, T4, T5) = (1, 3, 4, 2, 1), and (F1, F2, F3, F4, F5) = (3, 2, 3, 3, 4). If the jobs are partitioned into three batches {1, 2}, {3}, {4, 5}, then the output times (O1, O2, O3, O4, O5) = (5, 5, 10, 14, 14) and the costs of the jobs are (15, 10, 30, 42, 56), respectively. The total cost for a partitioning is the sum of the costs of all jobs. The total cost for the example partitioning above is 153. 

You are to write a program which, given the batch setup time and a sequence of jobs with their processing times and cost factors, computes the minimum possible total cost. 

Input

Your program reads from standard input. The first line contains the number of jobs N, 1 <= N <= 10000. The second line contains the batch setup time S which is an integer, 0 <= S <= 50. The following N lines contain information about the jobs 1, 2,..., N in that order as follows. First on each of these lines is an integer Ti, 1 <= Ti <= 100, the processing time of the job. Following that, there is an integer Fi, 1 <= Fi <= 100, the cost factor of the job.

Output

Your program writes to standard output. The output contains one line, which contains one integer: the minimum possible total cost.

Sample Input

5
1
1 3
3 2
4 3
2 3
1 4

Sample Output

153

Source

IOI 2002

 

【思路】

可以想见,当左边断开一下,右边每一段工程都要多乘一个S。

状态设计:dp[i]表示i到n的代价。

状态转移方程:dp[i] = min{dp[j] + (sum_t[i] - sum_t[j] + S) * sum_f[i]},其中sum_t和sum_f表示时间、系数的后缀和。

在i < k < p <= n + 1下,设dp[k]比dp[p]是个更优的转移选择,我们得到如下不等式:

\frac{dp[k] - dp[p]}{sum_t[k] - sum_t[p]} \leq sum_f[i], (i < k < p <= n + 1)

斜率优化一下,同时注意符号。

 

【代码】

//******************************************************************************
// File Name: POJ_1180.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年08月10日 星期五 15时34分52秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;

const int MAXN = 10005;

int n, s, head, tail;
int dq[MAXN];
ll sum_t[MAXN], sum_f[MAXN], dp[MAXN];

ll get_up(int k, int p)
{
	return dp[k] - dp[p];
}

ll get_down(int k, int p)
{
	return sum_t[k] - sum_t[p];
}

bool judge(int i, int j, int k)
{
	ll x1 = get_down(i, j), x2 = get_down(j, k);
	ll y1 = get_up(i, j), y2 = get_up(j, k);
	return x1 * y2 - y1 * x2 <= 0;
}

int main()
{
	scanf("%d %d", &n, &s);
	for (int i = 1; i <= n; i++)
		scanf("%lld %lld", &sum_t[i], &sum_f[i]);
	for (int i = n - 1; i >= 1; i--)
		sum_t[i] += sum_t[i + 1], sum_f[i] += sum_f[i + 1];
	dp[n + 1] = 0;
	head = tail = 0;
	dq[tail++] = n + 1;
	for (int i = n; i >= 1; i--) {
		while (tail - head >= 2 && get_up(dq[head], dq[head + 1]) >= sum_f[i] * get_down(dq[head], dq[head + 1])) head++;
		int k = dq[head];
		dp[i] = dp[k] + (sum_t[i] - sum_t[k] + s) * sum_f[i];
		while (tail - head >= 2 && judge(dq[tail - 2], dq[tail - 1], i)) tail--;
		dq[tail++] = i;
	}
	printf("%lld\n", dp[1]);
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值