FOJ Problem 2218 Simple String Problem

Problem Description
Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters. 

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring lengths?

 Input
The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

 Output

For each test case, output the answer of the question.

 Sample Input

4
25 5
abcdeabcdeabcdeabcdeabcde
25 5
aaaaabbbbbcccccdddddeeeee
25 5
adcbadcbedbadedcbacbcadbc
3 2

aaa Sample Output

 

6
150
21

0

 

AC代码:

 

# include <stdio.h>
# include <string.h> 
# include <algorithm>
using namespace std;
int w[20], dp[1<<17];
char s[2010];
int main(){
	int i, j, k, n, t, l, status;
	for(i=0; i<16; i++)
	w[i]=(1<<i);
	scanf("%d", &t);
	while(t--){
		memset(dp, 0, sizeof(dp));
		scanf("%d%d", &l, &k);
		getchar();
		scanf("%s", s);
		for(i=0; i<l; i++){
			status=0;
			for(j=i; j<l; j++){
				status=(status|w[s[j]-'a']);
				dp[status]=max(dp[status], j-i+1);
			}
		}
		int end=(1<<k)-1;
		for(i=0; i<=end; i++){
			for(j=0; j<k; j++){
				if(i&w[j])
				dp[i]=max(dp[i], dp[i^w[j]]);
			}
		}
		int Max=0;
		for(i=1; i<end; i++)
		Max=max(dp[i]*dp[(1<<k)-1-i], Max);  
		printf("%d\n", Max);
	}
	return 0;
}


 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值