1066 Root of AVL Tree (25 分)

37 篇文章 0 订阅

1066 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述在这里插入图片描述
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120
Sample Output 1:
70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

#include<bits/stdc++.h>
using namespace std;
struct node {
	int data, height;
	node* left, *right;
};
int getHeight(node* root) {
	if (root == nullptr) return -1;
	return root->height;
}
node* singleLeft(node* root) {
	node* A = root->left;
	root->left = A->right;
	A->right = root;
	root->height = max(getHeight(root->left), getHeight(root->right)) + 1;
	A->height = max(getHeight(A->left), root->height) + 1;
	return A; 
}
node* singleRight(node* root) {
	node* A = root->right;
	root->right = A->left;
	A->left = root;
	root->height = max(getHeight(root->left), getHeight(root->right)) + 1;
	A->height = max(getHeight(A->right), root->height) + 1;
	return A; 
}

node* doubleLeftRight(node* root) {
	root->left = singleRight(root->left);
	return singleLeft(root);
}

node* doubleRightLeft(node* root) {
	root->right = singleLeft(root->right);
	return singleRight(root);
}
node* CreateTree(node *root, int val) {
	if (root == nullptr) {
		root = (node*) malloc(sizeof(node));
		root->left = root->right = nullptr;
		root->data = val;
		root->height = 0;
	} else {
		if (val > root->data) {
			root->right = CreateTree(root->right, val);
			if (getHeight(root->left) - getHeight(root->right) == -2) {
				if (val > root->right->data) {
					root = singleRight(root); 
				} else if (val < root->right->data){
					root = doubleRightLeft(root); 
				}
			}
		} else if (val < root->data) {
			root->left = CreateTree(root->left, val);
			if (getHeight(root->left) - getHeight(root->right) == 2) {
				if (val < root->left->data) {
					root = singleLeft(root); 
				} else if (val > root->left->data){
					root = doubleLeftRight(root); 
				}
			}
		}
		root->height = max(getHeight(root->left), getHeight(root->right)) + 1;
	}
	return root;
	
}
int main() {
	int n, temp;
	bool flag1 = true, flag2 = true;
	scanf("%d", &n);
	node *root = nullptr;
	for (int i = 0; i < n; i++) {
		scanf("%d", &temp);
		root = CreateTree(root, temp);
	} 
	printf("%d", root->data);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值