poj 1733 Parity game(带权并查集)

链接:

http://poj.org/problem?id=1733


题目:

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source



题目大意:

有长度为n的0和1组成的字符串, 然后问第L和R位置之间有奇数个1还是偶数个1.

根据这些回答, 判断第几个是错误(和之前有矛盾)的。



分析与总结:

做这题做到吐血,只能说太坑爹了。

题目给的数据量非常大,所以需要离散化, 这里选择了用哈希来做。

两个区间如果相邻,那么奇数与奇数合并后就变成偶数, 偶数与偶数还是偶数,奇数与奇数还是奇数,那么显然可以用1代表奇数,0代表偶数, 用抑或操作符来计算合并之后是奇数还是偶数,这样比直接计算距离更快些。


然后让我吐血的地方是,一旦发现有矛盾了,要马上跳出循环, 后面的那些数据不用去管他了,否则如果用continue就WA。


代码:

#include<cstdio>
#include<cstring>

const int N = 6000;
int f[N], rank[N], head[N],next[N],st[N],n, m, rear;

inline void init(){
    rear = 0;
    memset(head, -1, sizeof(head));
    for(int i=0; i<N; ++i)
        f[i]=i, rank[i]=0;
}
int insert_hash(int num){
    int h = num%N;
    int u = head[h];
    while(u!=-1){
        if(st[u]==num) return u;
        u = next[u];
    }
    st[rear] = num;
    next[rear] = head[h];
    head[h] = rear++;
    return rear-1;
}
int find(int x){
    if(x==f[x]) return x;
    int fa=f[x];
    f[x] = find(f[x]);
    rank[x] ^= rank[fa];
    return f[x];
} 
inline bool Union(int x, int y, int d){
    int ra=find(x), rb=find(y);
    if(ra==rb){
        if(rank[x]^rank[y]!=d) return false;
        return true;
    }
    f[ra] = rb;
    rank[ra] = rank[x]^rank[y]^d;
    return true;
}

int main(){
    scanf("%d%d",&n,&m);
    init();
    int ans=0, a,b,d;
    char str[10];
    int i=0;
    for(i=0; i<m; ++i){
        scanf("%d %d %s",&a,&b,str);
        a = insert_hash(a-1);
        b = insert_hash(b);
        d = 0;
        if(str[0]=='o') d=1;
        if(!Union(a,b,d)){
            break; //直接跳出
        }
    }
    printf("%d\n", i);
    return 0;
}



——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值