Parity game POJ - 1733(带权并查集+离散化)

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
和之前一个题目挺像的,他给定的是一个闭区间,为了处理方便,需要将它改变为开区间,所以l–或者r++。这个题目n的数据范围特别大,所以需要离散化一下。奇偶总之就两个值,我们将偶数设置为0,奇数设置为1.并查集路径压缩的时候就不断的更新与父亲节点的距离。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;

const int maxx=1e5+100;
const int maxm=5e3+100;
struct node{
	int x,y,op;
}p[maxm];
int f[maxx],dis[maxx],a[maxx];
int n,m;

inline int getf(int u)
{
	int x;
	if(u!=f[u])
	{
		x=getf(f[u]);
		dis[u]=(dis[u]+dis[f[u]])%2;
		f[u]=x;
	}
	return f[u];
}
inline int merge(int u,int v,int val)
{
	int t1=getf(u);
	int t2=getf(v);
	if(t1==t2)
	{
		if((dis[u]-dis[v]+2)%2!=val) return 1;
		else return 0;
	}
	else
	{
		f[t1]=t2;
		dis[t1]=(dis[v]-dis[u]+2+val)%2;
		return 0;
	}
}
int main()
{	
	int cnt=0,x,y;char s[5],flag=0;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
	{
		scanf("%d%d%s",&x,&y,s);
		p[i].x=x-1,p[i].y=y,p[i].op=(s[0]=='e'?0:1);
		a[++cnt]=x-1;a[++cnt]=y;
	}
	sort(a+1,a+1+cnt);
	int len=unique(a+1,a+1+cnt)-a-1;
	for(int i=0;i<=len;i++) f[i]=i,dis[i]=0;
	int i;
	for(i=1;i<=m;i++)
	{
		p[i].x=lower_bound(a+1,a+1+len,p[i].x)-a;
		p[i].y=lower_bound(a+1,a+1+len,p[i].y)-a;
		if(merge(p[i].x,p[i].y,p[i].op))
		{
			flag=1;
			break;
		}
	}
	if(flag) printf("%d\n",i-1);
	else printf("%d\n",m);
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值