POJ 3641 Pseudoprime numbers(费马小定理,快速幂,数论)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8643 Accepted: 3630

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source




思路:
p 是素数时不满足条件;
满足条件的 p 是否满足 a^p%p=a ? 


参考代码:
#include<cstdio>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MYDD 1103

typedef long long ll;
using namespace std;

ll MOD(ll x,ll n,ll mod) {
	ll ans;
	if(n==0)
		return 1;
	ans=MOD(x*x%mod,n/2,mod);//采用递归
	if(n&1)//用于判断 n 的二进制最低位是否为 1
		ans=ans*x%mod;
	return ans;
}

ll issu(ll x) {//素数的判断
	if(x<2)
		return 0;//不是素数:返回 0
	for(ll j=2; j<=sqrt(x); j++)
		if(x%j==0)
			return 0;
	return 1;
}

int main() {
	ll p,a,Q_mod;
	while(scanf("%lld%lld",&p,&a)&&(p||a)) {
		if(issu(p)) {
			puts("no");//如果 p 是素数,直接输出
		} else {
			Q_mod=MOD(a,p,p);//快速幂 a^p%p 的结果 
			if(Q_mod==a) {
				puts("yes");
			} else
				puts("no");
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值