POJ3641(Pseudoprime numbers 费马小定理)


  
  
Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7393 Accepted: 3048

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题目大意:

根据以a为基的伪素数的定义,判断p是否是以a为基的伪素数.

解题思路:

由费马小定理可以知道:假如n是素数,若p是素数且a是整数,则满足a ^ n ≡ a (mod n).若存在正整数a不满足a ^ n ≡ a (mod n),那么n是合数.令a是一正整数,若n是合数且满足a ^ n ≡ a (mod n),则n称为以a 为基的伪素数。由费马小定理可以知道n必须为合数,所以当n为素数时,直接输出no表示不是伪素数,如果为合数,运用快速幂结果判断是否同余,如果同余输出yes,否则输出no.

AC代码:

#include<iostream>

using namespace std;

typedef long long ll;
bool isPrime(ll k)
{
	if(k == 2)
		return true;
	if(k % 2 == 0)
		return false;
	for(int i=3;i * i <= k;i+=2)
	{
		if(!(k % i))
		{
			return false;
		}
	}
	return true;
}

ll quick_mod(ll a,ll b,ll m)
{
	ll ans = 1;
	while(b)
	{
		if(b & 1)
		{
			ans = (ans * a) % m;
			b--;
		}
		b /= 2;
		a = a * a % m;
	}
	return ans;
}

int main()
{
	int m,n;
	while(scanf("%d%d",&m,&n) != EOF && m + n)
	{
		if(isPrime(m))
		{
			printf("no\n");
			continue;
		}
		ll ans;
		ans = quick_mod(n,m,m);
		if(ans == n)
		{
			printf("yes\n");
		}
		else
		{
			printf("no\n");
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值