HDOJ 1789 Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11357    Accepted Submission(s): 6676


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source


题意:

参加完 ACM 比赛,就赶紧完成作业吧。一组数据包括,作业的提交期限和作业对应的分值,求解的答案是,需要放弃的最小分数。


思路:

按照分值进行降序排列,用数组记录当天是否已经有作业的安排(排序后,已经被安排的天数,必然是分数比较高的作业),有的话,推迟到前一天写,以此类推。


参考代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;
// time  scores
struct Plan {
	int time;//截止时间是从今天开始计算
	int scores;
} dd[MYDD];

bool cmp_scores(Plan x,Plan y) {
	return x.scores>y.scores;
}

bool cmp_time(Plan x,Plan y) {//所有的作业都是踩点完成
	if(x.time!=y.time)
		return x.time<y.time;
	else
		return x.scores>y.scores;
}

int main() {
	int t,n;
	int have[MYDD];//用于标记当天是否已安排作业
	scanf("%d",&t);
	while(t--) {
		scanf("%d",&n);
		memset(have,0,sizeof(have));

		for(int j=0; j<n; j++)
			scanf("%d",&dd[j].time);//作业截止时间
		for(int j=0; j<n; j++)
			scanf("%d",&dd[j].scores);//作业对应分数

		sort(dd,dd+n,cmp_scores);

		int ans=0;//需要放弃的分数
		for(int j=0; j<n; j++) {//分数已按由大到小排序
			int have_i=0;//标记这个作业的分数能否完成,初始化不能完成
			for(int i=dd[j].time; i>=1; i--) {
				//因为 i 的缘故,折腾好久,i 应该严格的 >=1 毕竟是天数
				if(have[i]==0) { //向后推迟的 i 天,没有作业
					have[i]=1;//第 i 天标记有作业
					have_i=1;
					break;//可以完成这个作业
				}
			}
			if(!have_i)//不能完成作业扣除的分数
				ans+=dd[j].scores;
		}
		printf("%d\n",ans);
	}
	return 0;
}
/*

4
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值