HDU 5373 The shortest problem (递归调用,详解)

题目地址

http://acm.hdu.edu.cn/showproblem.php?pid=5373

The shortest problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 935    Accepted Submission(s): 479


Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
  
  
35 2 35 1 -1 -1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

思路:

判断这个数能否被11整除,当数十分大的时候会爆掉,简单的方法就是奇数位数的总和减去偶数位数的总和能否被11整除。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<math.h>
#include<stdlib.h>
using namespace std;
int tot;
__int64 ji,ou,sum;
void solve(int x){
    if(x>=10)    solve(x/10);
    if(tot%2==0){
        ou+=x%10;
    }
    else ji+=x%10;
    sum+=x%10;
    tot++;
    return;
}
int main()
{
    int ncase=0,n,t;
    while(cin>>n>>t)
    {
        ncase++;
        if(n==-1&&t==-1)
            break;
        ji=0,ou=0;
        sum=0,tot=0;
        solve(n);
       // printf("%d %d %d\n",ji,ou,sum);
        for(int i=0;i<t;i++){
            solve(sum);
        }
        printf("Case #%d: ",ncase);
      //  printf("%d %d %d\n",ji,ou,sum);
        if(abs(ji-ou)%11==0)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
代码用C++交就1400ms+险过,用G++交700ms+就过了



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值