1006: A+B 结束标志 scanf("%d", &n) == EOF (VI)

Description

Your task is to calculate the sum of some integers.

Input

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

#include <stdio.h>

int main()
{
    int n, i, a[100], sum=0;

    while(1)
    {
        if(scanf("%d", &n) == EOF)
            break;
        for(i=0; i<n; i++)
        {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        printf("%d\n", sum);
        sum = 0;
    }
    return 0;
}

6178753-545938280539ec7b.png

运行截图.png

Note:

题目丝毫没有提及如何结束输入,OJ默认读者知道是用 EOF 结束。
scanf函数返回成功读入的数据项数,读入数据时遇到了“文件结束”则返回EOF

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值