PAT-甲级-1006 Sign In and Sign Out

1006 Sign In and Sign Out (25)(25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

 

分析

先输入人数

再输入每个人的编号,来的时间和走的时间。每个人占一行

来的最早的人开门,最晚的关门

输出开门和关门的人的编号

 

思路

长度变长,考虑用链表(单链表,带头结点),包含三个数据元素(用string存)

先输入长度(即人数),根据人数循环,每次循环增加一个结点,使用头插法插入链表

然后遍历链表找出来的最早的和最晚的

 

问题

含有string数据元素的链表申请空间时不能用malloc,要用new

如果要malloc,由于题目给了编号的最大长度15,时间的格式是固定的, 可以使用char[ ]

 

代码

#include<stdio.h>
#include<iostream>
#include <stdlib.h>
#include<iomanip>
#include <string>
#include <malloc.h>
using namespace std;
typedef struct LNode{
    string id;
    string in_time,out_time;
    struct LNode *next;
}LNode;
void creat(LNode *&C){
    C = (LNode*)malloc(sizeof(LNode));
    C->next = NULL;
}
void Insert(LNode *&C,string str[3]){
    LNode *s;
    s = C;
    s = new LNode();
    s->id = str[0];
    s->in_time = str[1];
    s->out_time = str[2];
  //  cout<<s->id<<" "<<s->in_time<<" "<<s->out_time;
    s->next = C->next;
    C->next = s;
}
void findlist(LNode *C,string &open,string &lock){
    LNode *p = C->next;
    string max_str,min_str;
    open = p->id;
    lock = p->id;
    min_str = p->in_time;
    max_str = p->out_time;
    while(p->next!=NULL){
        p = p->next;
        if(p->in_time<min_str) {
            min_str = p->in_time;
            open = p->id;
        }
        if(p->out_time>max_str) {
            max_str = p->out_time;
            lock = p->id;
        }
    }
}
int main(){
    LNode *s;
    creat(*&s);
    int m;
    cin>>m;
    int i = m;
    while(i){
        string str[3];
        cin>>str[0]>>str[1]>>str[2];
 //       cout<<str[0]<<" "<<str[1]<<" "<<str[2];
        Insert(s,str);
        i--;
    }
    string open,lock;
    findlist(s,open,lock);
    cout<<open<<" "<<lock;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值