PAT-甲级-1006 Sign In and Sign Out (25 分)

60 篇文章 0 订阅
20 篇文章 0 订阅

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:每天第一个来机房的人负责开门,最后一个走的负责关门;此次的任务就是负责找出最先来和最晚走的人的id。
解题思路:

  • 创建两个map<int,string> unlock和lock,其中int表示将时间转换成以秒(s)为单位的数值,string存储其id;
  • 因为map会以key非递减排序,所以unlock的第一个元素的value就是最先来的id,lock的逆序第一个元素就是最晚走id;
  • 因为map的end是一个不存在的空值,所以要用reverse_iterator得到逆序第一个元素指针。
    #include <iostream>
    #include <string>
    #include <algorithm>
    #include <map>
    using namespace std;
    
    #define rep(i,j,k)    for(int i=j;i<k;i++)
    int main(){
        int n,s,f,m;
        string id;
        map<int,string> unlock;
        map<int,string> lock;
        cin>>n;
        rep(i,0,n){
            cin>>id;getchar();
            scanf("%d:%d:%d",&s,&f,&m);getchar();
            unlock[s*3600+f*60+m] = id;
            scanf("%d:%d:%d",&s,&f,&m);
            lock[s*3600+f*60+m] = id;
        }
        map<int,string>::reverse_iterator rit=lock.rbegin();
        cout<<unlock.begin()->second<<" "<<rit->second;
        return 0;
    }
    

     

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值