Poj 1988 Cube Stacking(带权并查集)

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 24448 Accepted: 8560
Case Time Limit: 1000MS
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
Source
USACO 2004 U S Open

/*
带权并查集.
sum[i]表示以i为根的集合的元素个数.
cnt[i]表示i元素到祖宗节点的距离.
father[i]表示路径压缩后i的祖宗.
然后查的时候只需要知道
这个块在哪个正方体里
和它在这个正方体里的相对位置就可以了. 
*/
#include<iostream>
#include<cstdio>
#define MAXN 30001
using namespace std;
int n,m,father[MAXN],sum[MAXN],top[MAXN],cnt[MAXN];
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') x=x*10+ch-48,ch=getchar();
    return x*f;
}
inline int find(int x)
{
    if(x==father[x]) return x;
    int fa=father[x];
    father[x]=find(father[x]);
    cnt[x]+=cnt[fa];
    return father[x];
}
inline int merge(int x,int y)
{
    father[y]=x;
    cnt[y]+=sum[x];
    sum[x]+=sum[y];
    sum[y]=0;
}
inline int abs(int x)
{
    return x<0?-x:x;
}
int main()
{
    int x,y;
    n=read();
    for(int i=1;i<=MAXN;i++) father[i]=i,sum[i]=1;
    char ch[4];
    while(n--)
    {
        cin>>ch+1;
        if(ch[1]=='M') 
        {
            x=read(),y=read();
            int l1=find(x),l2=find(y);
            merge(l1,l2);
        }
        else {
            x=read();int l1=find(x);
            printf("%d\n",sum[l1]-cnt[x]-1);
        }   
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值