Balanced Number
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 5692 Accepted Submission(s): 2727
Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10
18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2 0 9 7604 24324
Sample Output
10 897
Author
GAO, Yuan
Source
数位DP第一题,困难无比,花费半个晚上。
第一次看到这种题目,去搜了搜资料,套了此类题目大略的格式。
一个数要平衡,求所有数位上数与到平衡点距离的乘积之和,距离有正有负,最后和为0就表示满足要求。
#include <cstdio>
#include <iostream>
#include <string.h>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
using namespace std;
typedef long long ll;
int num[25];
ll dp[20][20][2005];
ll dfs(ll len,ll mid,ll sum,bool HaveLimit) {
if (!len)
return sum==0?1:0;
if (sum<0) return 0;
if (!HaveLimit&&dp[len][mid][sum]!=-1)
return dp[len][mid][sum];
int limit,i;
if (HaveLimit) limit=num[len]; else limit=9;
ll ans=0;
for (i=0;i<=limit;i++) {
ans+=dfs(len-1,mid,sum+(len-mid)*i,HaveLimit&&i==limit);
}
if (!HaveLimit) dp[len][mid][sum]=ans;
return ans;
}
ll solve(ll limit) {
if (limit==-1) return 0;
ll k=limit,cnt=0;
while (k>0) {
cnt++;
num[cnt]=k%10;
k/=10;
}
ll ans=0;
for (int i=cnt;i>=1;i--) {
ans+=dfs(cnt,i,0,1);
}
return ans-cnt+1; //去除长度大于1的0
}
int main() {
int t,q,i,j;
ll x,y;
scanf("%d",&t);
for (q=1;q<=t;q++) {
scanf("%lld%lld",&x,&y);
memset(dp,-1,sizeof(dp));
ll ans=solve(y)-solve(x-1);
printf("%lld\n",ans);
}
return 0;
}