HDU 3709 Balanced Number 数位dp

F - Balanced Number
Time Limit:5000MS     Memory Limit:65535KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].
 

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10  18).
 

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input

     
     
2 0 9 7604 24324
 

Sample Output

     
     
10 897
 找平衡数
定义平衡数 以数中的一个为中心然后两边的力矩要相等
想了半天没有很好的思路
看了网上的代码发现只要枚举每一位数然后以这个数按位dp就行了
dp[i,j,pre]表示i位数以j为中心的时候左边的比重为pre
注意最后要排除0 ,00, 000,0000,00000,重复的情况所以答案要ans-len+1
ACcode:
#include <cstdio>
#include <cstring>
#define ll long long
ll dp[20][20][1386];
int data[20];
ll dfs(int len,int pos,int pre,bool limit){
    if(!len) return pre==0;
    if(pre<0)return 0;
    if(!limit&&dp[len][pos][pre]!=-1)return dp[len][pos][pre];
    int ed=limit?data[len]:9;
    ll ans=0;
    for(int i=0;i<=ed;++i)
        ans+=dfs(len-1,pos,pre+i*(len-pos),limit&&i==ed);
    return limit?ans:dp[len][pos][pre]=ans;
}
ll fun(ll n){
    int len=0;
    while(n){
        data[++len]=n%10;
        n/=10;
    }
    ll ans=0;
    for(int i=1;i<=len;++i)
        ans+=dfs(len,i,0,1);
    return ans-len+1;
}
void doit(){
    ll x,y;
    scanf("%I64d%I64d",&x,&y);
    printf("%I64d\n",fun(y)-fun(x-1));
}
int main(){
    int loop;memset(dp,-1,sizeof(dp));
    scanf("%d",&loop);
    while(loop--)doit();
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值