Hdu 2568 How far away? LCA

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16755    Accepted Submission(s): 6397


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3486  2874  2888  3234  2818 


LCA模板题。

不多说了,直接贴代码。

个人使用的是ST在线算法。


//LCA
#include <cstdio>
#include <iostream>
#include <string.h>
#include <string> 
#include <map>
#include <queue>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <bitset>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
const int maxn=40005,inf=0x3f3f3f3f;
const ll llinf=0x3f3f3f3f3f3f3f3f; 
const ld pi=acos(-1.0L);
int head[maxn],f[maxn],dist[maxn],a[maxn*2],mind[maxn*2][20],dep[maxn*2];
bool visit[maxn];
int dfn,num;

struct Edge {
	int from,to,pre,dist;
};
Edge edge[maxn*2];

void addedge(int from,int to,int dist) {
	edge[num]=(Edge){from,to,head[from],dist};
	head[from]=num++;
	edge[num]=(Edge){to,from,head[to],dist};
	head[to]=num++;
}

void dfs(int now,int step) {
	f[now]=++dfn;a[dfn]=now;dep[dfn]=step;
	visit[now]=1;
	for (int i=head[now];i!=-1;i=edge[i].pre) {
		int to=edge[i].to;
		if (!visit[to]) {
			dist[to]=dist[now]+edge[i].dist;
			dfs(to,step+1);
			a[++dfn]=now;
			dep[dfn]=step;
		}
	}
}

void init(int n) {
	mem0(mind);
	int i,j;
	for (i=1;i<=n;i++) mind[i][0]=i;
	for (j=1;(1<<j)<=n;j++) {
		for (i=1;i+(1<<j)-1<=n;i++) {
			int p=mind[i][j-1],q=mind[i+(1<<(j-1))][j-1];
			if (dep[p]<dep[q]) mind[i][j]=p; else mind[i][j]=q;
		}
	}
}

int find(int l,int r) {
	int k=0;
	while ((1<<(k+1))<=(r-l+1)) k++;
	int p=mind[l][k],q=mind[r-(1<<k)+1][k];
	return dep[p]<dep[q]?p:q;
}

int main() {
int cas;
scanf("%d",&cas);
while (cas--) {
	int n,q,i,j,x,y,z;
	scanf("%d%d",&n,&q);
	num=0;
	memset(head,-1,sizeof(head));
	for (i=1;i<n;i++) {
		scanf("%d%d%d",&x,&y,&z);
		addedge(x,y,z);
	}
	dfn=0;
	mem0(visit);
	dist[1]=0;
	dfs(1,0);
	init(dfn);
	for (i=1;i<=q;i++) {
		scanf("%d%d",&x,&y);
		int p;
		if (f[x]>f[y]) p=a[find(f[y],f[x])]; else p=a[find(f[x],f[y])];
		int ans=dist[x]+dist[y]-2*dist[p];
		printf("%d\n",ans);
	}
}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值