E - 05

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.


题意:

某人搭了一间有N间牛舍的小屋,c支牛,每个牛距离都不想太紧,问牛之间能达到得最小距离!!一看最大值的最小值问题,大多数就要使用二分算法!

思路:

采用二分查找的思想,对中间值进行寻找,类似于课堂上讲的那个移动石头的题目!

代码:

#include<iostream>
#include<string>
#include<stdio.h>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 100005
int a[N];
int main()
{
	//freopen("1.txt","r",stdin);
	int n,c,i,mid,lp,rp;
	scanf("%d %d",&n,&c);
	for(i=1;i<=n;i++)
	{
	    scanf("%d",&a[i]);
	}
	sort(a,a+n);
    lp=0;rp=2000000000;
	while(lp<rp)//注意是>号,而不用等于,注意这个细节!
	{
	    int cnt=1,j=1; //记录最小时放的牛
	    mid=(lp+rp)/2;//首先假设mid为最大值的最小值!
	    for(i=2;i<=n;i++)
	    {
	        if(a[i]-a[j]>mid) //细节处理
	        {cnt++;j=i;}
        }
        if(cnt<c)
        rp=mid;
        else
        lp=mid+1;
    }
    printf("%d",rp);
	return 0;
}

心得:

典型的二分查找,还是理解有点不透彻!!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值