Monkey and Banana

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.<br>
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
University of Ulm Local Contest 1996
 

给出n种类型的木块,求用这些木块可以堆起的最大高度,要求上边的木快的长和宽都要严格小于下边。

思路:

首先计算出每个物块以不同的面作为底面的面积,然后由小到大进行排序,根据题目要求进行判断,求得最大值即可!

代码:

#include <bits/stdc++.h>
using namespace std;
struct block
{
       int area;
       int height;
       int width;
       int length;
};
bool cmp(block &a,block &b)
{
     return a.area>b.area;
 }
int main()
{
    ios::sync_with_stdio(false);
    int kinds;
    int i,j,l,w,h,s=1;
    int max;
    int k;
    block b[100];
    vector<int> dp(300);
    block temp;
    while(1)
    {
       k=0;
      cin>>kinds;
      if(kinds==0) break;
      for(i=0;i<kinds;i++)
      {
      cin>>l>>w>>h;
      temp.width=l;
	  temp.length=w;
      temp.area=l*w;
	  temp.height=h;
      b[k++]=temp;
      temp.width=l;
	  temp.length=h;
      temp.area=l*h;
	   temp.height=w;
      b[k++]=temp;
      temp.width=h;
	  temp.length=w;
      temp.area=h*w;
	  temp.height=l;
      b[k++]=temp;
      }
	sort(b,b+kinds*3,cmp);
    dp[0]=b[0].height;
    for(i=1;i<kinds*3;i++)
    {
         dp[i]=b[i].height;
         for(j=0;j<i;j++)
         {
         if( (b[i].width<b[j].width && b[i].length<b[j].length)||(b[i].width<b[j].length && b[i].length<b[j].width) )
            if( dp[j]+b[i].height>dp[i])
              dp[i]=dp[j]+b[i].height;
         }
    }
    max=0;
    for(i=0;i<kinds*3;i++)
      if(dp[i]>max)
       max=dp[i];
       printf("Case %d: maximum height = %d\n",s,max);
      s++;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值