HDU 2586 最近公共祖先 LCA在线算法

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13294    Accepted Submission(s): 4974


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3486  2874  2888  3234  2818 

 


给一棵树,询问u,v之间的距离

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <vector>

using namespace std;
const int N = 50005;

vector<int> v[N],w[N],query[N],num[N];
int pre[N],dist[N],ans[N];
bool vis[N];
int n;

void Init()
{
    for(int i=1; i<=n; i++)
    {
        v[i].clear();
        w[i].clear();
        query[i].clear();
        num[i].clear();
        pre[i] = i;
        dist[i] = 0;
        vis[i] = false;
    }
}

int Find(int x)
{
    if(pre[x] != x)
        pre[x] = Find(pre[x]);
    return pre[x];
}

void Union(int x,int y)
{
    x = Find(x);
    y = Find(y);
    if(x == y) return;
    pre[y] = x;
}

void Tarjan(int cur,int val)
{
    vis[cur] = true;
    dist[cur] = val;
    int size = v[cur].size();
    for(int i=0;i<size;i++)
    {
        int tmp = v[cur][i];
        if(vis[tmp]) continue;
        Tarjan(tmp,val + w[cur][i]);
        Union(cur,tmp);
    }
    int Size = query[cur].size();
    for(int i=0;i<Size;i++)
    {
        int tmp = query[cur][i];
        if(!vis[tmp]) continue;
        ans[num[cur][i]] = dist[cur] + dist[tmp] - 2*dist[Find(tmp)];
    }
}

int main()
{
    int T,Q,x,y,z;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&Q);
        Init();
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            v[x].push_back(y);
            w[x].push_back(z);
            v[y].push_back(x);
            w[y].push_back(z);
        }
        for(int i=0;i<Q;i++)
        {
            scanf("%d%d",&x,&y);
            query[x].push_back(y);
            query[y].push_back(x);
            num[x].push_back(i);
            num[y].push_back(i);
        }
        Tarjan(1,0);
        for(int i=0;i<Q;i++)
           printf("%d\n",ans[i]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值