ACM: 一道组合数学的题 poj3252

 

Round Numbers

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

 

题意: 定义一种数叫round number,它的二进制数中 0的个数 >= 1的个数. 输入start ~ finish,输出这种数的个数.

个人思路:

1.一开始的第一想法,暴力打表,发现2,000,000,000天文数字啊.

2.第二个想法,继续打表,不过这次是将一个数按二进制数8 or 16位拆分判断.

3.但是扫描1~2,000,000,000时超时了.

4.查阅资料发现规律,先计算2^n的个数.排列组合问题( 2^n < number < 2^(n+1) ).

5.难计算的是2^n ~ number中round number的个数.

假设:

mid(len,i) 表示len位数的二进制数,i个0的数的个数. str[i] 表示 该二进制数.

递推关系:

str[i-1] == 0 时, mid(len-1,i-1)

str[i-1] == 1时, mid(len-1,i)  + c[len-2][i-1]

(c[len2][i-1]: 排序组合C几几. 表示要加上str[i-1]=0的另一分支的个数.) 关键

 

代码:

#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;

int c[35][35];
int num[33];
int a[33];

void init()
{
       memset(num,0,sizeof(num));
       memset(c,0,sizeof(c));
       memset(a,0,sizeof(a));
       int i,j;
       c[1][0]= 1;
       c[1][1] = 1;
 
       for(i = 2; i <= 32; i++)
      {
            c[i][0] = 1;
            for(j = 1; j <= i; j++)
                 c[i][j] = c[i-1][j] + c[i-1][j-1];
      }
 
       num[1] = 0;
       for(i = 2; i <= 32; i++)
       
             for(j = (i+1)/2; j < i; j++)
                  num[i] += c[i-1][j];
//  cout << num[i] << endl;
       }
}

int binary(int a,int str[])
{
      int i = 1;
      while(a != 0)
     {
           str[i++] = a % 2;
          /= 2;
     }
     return i-1;
}

int mid(int len,int i,int str[])
{
      if(i >= len || i < 0)
         return 0;
      if( (len == 1 && i == 0) || (len == 2 && i == 1) )
         return 1;
      if(str[len-1] == 0)
          return mid(len-1,i-1,str);
      else if(str[len-1] == 1)
          return c[len-2][i-1] + mid(len-1,i,str);
}

int jishu(int a)
{
      int str[33];
      memset(str,0,sizeof(str));
      int result = 0;
      int i;
      int len = binary(a,str);
      for(i = 1; i < len; ++i)
      {
            result += num[i];
      }

for(i = (len+1)/2; i < len; ++i)
       {
            result += mid(len,i,str);
       }

return result;
}

 

int main()
{
       init();
 
       int start , finish;
       while(scanf("%d %d",&start,&finish) != EOF)
     {
            int result;

result = jishu(finish) - jishu(start-1);
            printf("%d\n",result);
     }

return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值