POJ - 3252 Round Numbers 数位DP

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation ofN has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively  Start and  Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start..  Finish
Sample Input
2 12
Sample Output

6



题意:求n-m中二进制表示0的数量不小于1的数的个数。


dp[len][s0][s1]表示长度问len 0的数量为s0,1的数量为s1的情况的个数,注意二进制要从1算起

所以需要开一个标记判断是否首位为1.

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm = 45;
int dp[maxm][maxm][maxm], d[maxm];
int dfs(int len, int m, int s0, int s1, int flag)
{
	if (len < 0) return s0 >= s1;
	if (!flag && !m&&dp[len][s0][s1] != -1) return dp[len][s0][s1];
	int k = flag ? d[len] : 1;
	int ans = 0;
	for (int i = 0;i <= k;i++)
	{
		if (m)
		{
			if (i == 1) ans += dfs(len - 1, 0, s0, s1 + 1, flag&&i == k);
			else ans += dfs(len - 1, 1, s0, s1, flag&&i == k);
		}
		else
		{
			if (i == 1) ans += dfs(len - 1, 0, s0, s1 + 1, flag&&i == k);
			else ans += dfs(len - 1, 0, s0 + 1, s1, flag&&i == k);
		}
	}
	if (!flag) dp[len][s0][s1] = ans;
	return ans;
}
int query(int n)
{
	int len = 0;
	while (n) d[len++] = n % 2, n /= 2;
	return dfs(len - 1, 1, 0, 0, 1);
}
int main()
{
	int n, i, j, k, sum, a, b;
	memset(dp, -1, sizeof(dp));
	while (scanf("%d%d", &a, &b) != EOF)
		printf("%d\n", query(b) - query(a - 1));
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值